Automated Chrome hides text in CodeceptJS WebdriverIO test

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Automated Chrome hides text in CodeceptJS WebdriverIO test

Paul Vincent Beigang

I have a fresh install of Chrome Version 67.0.3396.87 and followed the https://codecept.io/quickstart/to init a project and create the following test:


Feature('Hidden Text');

Scenario('test something', (I) => {
    I.amOnPage('/');
    pause();
});


The codecept.json config is pretty standard:


{
  "tests": "./*_test.js",
  "timeout": 10000,
  "output": "./output",
  "helpers": {
    "WebDriverIO": {
      "url": "https://codecept.io",
      "browser": "chrome"
    }
  },
  "include": {
    "I": "./steps_file.js"
  },
  "bootstrap": false,
  "mocha": {},
  "name": "chrome-missing-text"
}


When I run the test all text is hidden:


enter image description here


Interestingly this behaviour also applies to the chrome settings itself (also dev tools), but I can select and copy the "hidden" text and paste it sucessfully:


enter image description here


I tried to run selenium-standalone via selenium-standalone start, this runs selenium-standalone version 3.8.1 and ChromeDriver 2.37.544337 and also with latest selenium-standalone version 3.12.0 and ChromeDriver 2.4.0 downloaded, started manually via java -Dwebdriver.chrome.driver=chromedriver -jar selenium-server-standalone-3.12.0.jar, it did not changed the result that Chrome hides all text visually.


I am on Mac OS X 10.13.5.


What else can I do to troubleshoot & fix the issue?

I am unsure where to ask this question since I am not sure which part of the stack is causing the problem.


Please note: This is a cross post of https://stackoverflow.com/questions/50833492/automated-chrome-hides-text-in-codeceptjs-webdriverio-test 

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/33352011-32bc-4229-a3f1-48b750a90f7b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.