Code runs fine in debug mode but not working in run mode

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Code runs fine in debug mode but not working in run mode

padmaja1689

0down vote

I have to set value to "Gross Amount" field.But this field is having regular expressions on that and when we enter value and move to next field , the entered value is converting as "$1000.00" formate. Here is 1000 has given as example.

Code is working fine in debug mode and setting value where as in run mode it is not working


favoritI have to set value to "Gross Amount" field.But this field is having regular expressions on that and when we enter value and move to next field , the entered value is converting as "$1000.00" formate. Here is 1000 has given as example.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/e67e2af6-f79d-46d0-acb1-ba34879fb304%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Keywords and HTML Code and LOGs.docx (21K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Code runs fine in debug mode but not working in run mode

total QA
This might be due to wait issue. Please insert wait statements, and check the code again.
Becoz during debug mode, we will control the execution flow.

Thanks,
total-qa.com

On Friday, June 15, 2018 at 9:43:36 AM UTC+5:30, [hidden email] wrote:

0down vote
0down vote<a href="https://stackoverflow.com/questions/50856313/code-runs-fine-in-debug-mode-but-not-working-in-run-mode#" title="Click to mark as favorite question (click again to undo)" style="margin-right:auto;margin-bottom:2px;margin-left:auto;font-style:inherit;font-variant:inherit;font-weight:inherit;font-stretch:inherit;line-height:inherit;font-family:inherit;font-size:1px;vertical-align:baseline;color:rgb(0,119,204);background-image:url(&quot;../../Img/unified/sprites.svg?v=438582dc9e27&quot;),none;background-repeat:no-repeat;overflow:hidden;display:block;width:40px;min-height:30px;background-position:0px -120px" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fstackoverflow.com%2Fquestions%2F50856313%2Fcode-runs-fine-in-debug-mode-but-not-working-in-run-mode%23\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHXk2JXkmjdlf45M3KSRG5vOfTpjw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fstackoverflow.com%2Fquestions%2F50856313%2Fcode-runs-fine-in-debug-mode-but-not-working-in-run-mode%23\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHXk2JXkmjdlf45M3KSRG5vOfTpjw&#39;;return true;">favorite

I have to set value to "Gross Amount" field.But this field is having regular expressions on that and when we enter value and move to next field , the entered value is converting as "$1000.00" formate. Here is 1000 has given as example.

Code is working fine in debug mode and setting value where as in run mode it is not working


<a href="https://stackoverflow.com/questions/50856313/code-runs-fine-in-debug-mode-but-not-working-in-run-mode#" title="Click to mark as favorite question (click again to undo)" style="margin-right:auto;margin-bottom:2px;margin-left:auto;font-style:inherit;font-variant:inherit;font-weight:inherit;font-stretch:inherit;line-height:inherit;font-family:inherit;font-size:1px;vertical-align:baseline;color:rgb(0,119,204);background-image:url(&quot;../../Img/unified/sprites.svg?v=438582dc9e27&quot;),none;background-repeat:no-repeat;overflow:hidden;display:block;width:40px;min-height:30px;background-position:0px -120px" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fstackoverflow.com%2Fquestions%2F50856313%2Fcode-runs-fine-in-debug-mode-but-not-working-in-run-mode%23\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHXk2JXkmjdlf45M3KSRG5vOfTpjw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fstackoverflow.com%2Fquestions%2F50856313%2Fcode-runs-fine-in-debug-mode-but-not-working-in-run-mode%23\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHXk2JXkmjdlf45M3KSRG5vOfTpjw&#39;;return true;">favoritI have to set value to "Gross Amount" field.But this field is having regular expressions on that and when we enter value and move to next field , the entered value is converting as "$1000.00" formate. Here is 1000 has given as example.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/06adb04e-75f8-4407-835e-6f2592654f63%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.