Getting Started with Selenium

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Getting Started with Selenium

GW-5
Greetings all.  I've come across Selenium, and think it is just what I need to do testing of customer-facing parts of our application.  However, after reading documentation, downloading Selenium, examining code, running it, I have not been able to get things set up quite the way I think it best could be.  I am able to run the TestRunner style testing, but I am much more interested in the Driven mode (if it's still called that).  Let me describe what we're trying to do:

I have full control over the HTML/PHP of the AUT being served.  I can modify it at will and install whatever Selenium-related files are needed to facilitate testing using Selenium.  However, I am not at liberty to install new interpreters or such, so only Perl and PHP are at my disposal on that machine.  That is, not Ruby, not Python, not Java.

Of course, I have full control over the [separate] machine running the browser(s) which are used to test the AUT.  I have Ruby, Python, Perl and Java on it, and so can run whatever Selenium needs from this machine.  It is sufficient to test only with Firefox.  This client machine is running Linux.

I am getting inklings that there exist thing(s) called Selenium Server or Selenium Remote Control.  These are not really in the documentation that I found, and I assume they are relatively recent developments.  Searching the forums tells me that some people might be using selenium_server.py in conjunction with tests written in Ruby.

Anyway, I'm hoping some people can point me in the right direction to help me get Selenium set up so that I can write tests in Ruby to test the AUT.

Thanks in advance;
Pistos
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.openqa.org/thread.jspa?threadID=1886&messageID=5339#5339

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Getting Started with Selenium

Joe Attardi
Selenium Remote Control is a separate project and can be found at http://www.openqa.org/selenium-rc/. Selenium RC is what used to be known as "Driven Mode".

On 5/4/06, Pistos <[hidden email]> wrote:
Greetings all.  I've come across Selenium, and think it is just what I need to do testing of customer-facing parts of our application.  However, after reading documentation, downloading Selenium, examining code, running it, I have not been able to get things set up quite the way I think it best could be.  I am able to run the TestRunner style testing, but I am much more interested in the Driven mode (if it's still called that).  Let me describe what we're trying to do:

I have full control over the HTML/PHP of the AUT being served.  I can modify it at will and install whatever Selenium-related files are needed to facilitate testing using Selenium.  However, I am not at liberty to install new interpreters or such, so only Perl and PHP are at my disposal on that machine.  That is, not Ruby, not Python, not Java.

Of course, I have full control over the [separate] machine running the browser(s) which are used to test the AUT.  I have Ruby, Python, Perl and Java on it, and so can run whatever Selenium needs from this machine.  It is sufficient to test only with Firefox.  This client machine is running Linux.

I am getting inklings that there exist thing(s) called Selenium Server or Selenium Remote Control.  These are not really in the documentation that I found, and I assume they are relatively recent developments.  Searching the forums tells me that some people might be using selenium_server.py in conjunction with tests written in Ruby.

Anyway, I'm hoping some people can point me in the right direction to help me get Selenium set up so that I can write tests in Ruby to test the AUT.

Thanks in advance;
Pistos
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.openqa.org/thread.jspa?threadID=1886&messageID=5339#5339

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Getting Started with Selenium

GW-5
In reply to this post by GW-5
I should mention that the AUT is almost entirely HTTPS.
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.openqa.org/thread.jspa?threadID=1886&messageID=5340#5340

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Getting Started with Selenium

GW-5
In reply to this post by Joe Attardi
Thanks, this helped me a lot.  I managed to get it going to work with non-HTTPS sites.  I am going to try the various workarounds suggested for HTTPS now.
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.openqa.org/thread.jspa?threadID=1886&messageID=5353#5353

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]