Problem with Selenium RC

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with Selenium RC

jignesh-3
jignesh wrote:

Hi,
     I am having problem with selenium remote control version  when Iam running this below command from the command line

D:\selenium-remote-control"C:\java -jar selenium-server.jar -htmlSuite "D:\firefox\firefox.exe" "http://www.google.com" "C:\selenium-0.6.0\selenium\tests\GoogleTestSuite.html" "C:\SELRES\results.html" -timeout 30 browser gets opened with the following  message

*Google**  Not Found

The requested URL |/selenium-server/TestRunner.html?auto=true&test=http://www.google.com/selenium-server/TestSuite.html|* was not found on this server.
Regards,
Jignesh C.Patel


Yes, that's what I'd expect.  The problem here is that you're specifying the path to firefox as

"D:\firefox\firefox.exe" instead of using

"*firefox d:\firefox\firefox.exe"

When you use *firefox, you inform the server that your browser is a Firefox browser and that you want it to automatically configure the proxy. When you just use the command path, we assume that you've manually configured the proxy and that we aren't supposed to fool around with it. If the proxy isn't configured, you get this 404 error.

-Dan



As you have said, i have modified the command and executed again as follows

D:\selenium-remote-control-0.7.1\server >java -jar selenium-server.jar -htmlSuite  "*firefox D:\firefox\firefox.exe" "http://www.google.com"  "C:\selenium-0.6.0\selenium\tests\GoogleTestSuite.html" "C:\SELRES\results.html" -timeout 40

"browser gets open with blank page  and waits as long , In command prompt generating the log as "

May 8, 2006 3:52:35 PM org.mortbay.http.HttpServer doStart
INFO: Version Jetty/0.7.1
May 8, 2006 3:52:35 PM org.mortbay.util.Container start
INFO: Started HttpContext[/,/]
May 8, 2006 3:52:35 PM org.mortbay.util.Container start
INFO: Started HttpContext[/selenium-server,/selenium-server]
May 8, 2006 3:52:35 PM org.mortbay.util.Container start
INFO: Started HttpContext[/selenium-server/driver,/selenium-server/driver]
May 8, 2006 3:52:35 PM org.mortbay.http.SocketListener start
INFO: Started SocketListener on 0.0.0.0:4444
May 8, 2006 3:52:35 PM org.mortbay.util.Container start
INFO: Started org.mortbay.jetty.Server@8814e9
Preparing Firefox profile...
*** nsExtensionManager::_disableObsoleteExtensions - failure, catching exception so finalize window can close
*** loading the extensions datasource

Regards,
Jignesh C.Patel

Reply | Threaded
Open this post in threaded view
|

Re: Problem with Selenium RC

Dan Fabulich
jignesh wrote:

> As you have said, i have modified the command and executed again as follows
>
> *D:\selenium-remote-control-0.7.1\server >*java -jar selenium-server.jar
> -htmlSuite  *"*firefox D:\firefox\firefox.exe"* "http://www.google.com"
> "C:\selenium-0.6.0\selenium\tests\GoogleTestSuite.html"
> "C:\SELRES\results.html" -timeout 40
>
> "browser gets open with blank page  and waits as long , In command prompt

Are you using Firefox 1.5?  Only Firefox 1.5 supports automated proxy
configuration.

-Dan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]