Running Java Driven Mode with remote server and remote selenium

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Running Java Driven Mode with remote server and remote selenium

GW-5
I'm trying to run in driven mode from a test client against an application running on another machine.  I'm fortunate in that I am able to install selenium in the same app server as the server under test, which makes me think that I should not have a cross-scripting issue.

But when I try to connect to the server, and I modify DefaultSelenium to allow connections other than to localhost:8080, I get a 302 response from the server.

Everything I look at on the remote driven mode seems to be dedicated to getting round the cross-scripting problem.  Where should I be looking to get driven mode to work in this seemingly simple manner?

My apologies if there is an explanation out there, I just haven't been able to find it.
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.openqa.org/thread.jspa?threadID=1215&messageID=3481#3481

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Running Java Driven Mode with remote server and remote selenium

Dan Fabulich
Andy wrote:

> Everything I look at on the remote driven mode seems to be dedicated to
> getting round the cross-scripting problem.  Where should I be looking to
> get driven mode to work in this seemingly simple manner?

The 0.6.0 release of Java driven mode doesn't really work right now.  A
new version will be available soon that does.  (It will even have
documentation!)

Sorry for the inconvenience.

-Dan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Running Java Driven Mode with remote server and remote selenium

GW-5
Thanks Dan, I had just been looking at running the CommandBridge on the server and using the CommandBridge client to send the commands to it.  

Is it worth persuing this route or should I just wait for the next release?

Regards Andy
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.openqa.org/thread.jspa?threadID=1215&messageID=3486#3486

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Running Java Driven Mode with remote server and remote selenium

Dan Fabulich
Andy wrote:

> Is it worth persuing this route or should I just wait for the next
> release?

I'd wait... it should be coming in the next few weeks (no promises
though).

-Dan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]