Selenium could not able to identify elements while running the application in Edge Chromium Browser

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Selenium could not able to identify elements while running the application in Edge Chromium Browser

Veena Tarak
Hi All,

I am receiving "Return value must be dictionary" while trying to run the selenium script in Edge chromium browser.

getting this error right after the browser lauches.

This issue happens to only my application. same code is working for other web application (like google and gmail)

Could any one let us know what's wrong with my application.

Note: The same working with Chrome browser , seeing this only for Edge Chromium

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/8d2789fe-a1fa-47b5-bdc0-214094d8d59co%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Selenium could not able to identify elements while running the application in Edge Chromium Browser

Joe Ward
Without meaning to sound obvious, whatever line you are getting that exception is not returning a dictionary (https://docs.python.org/3/tutorial/datastructures.html#dictionaries). On Google and Gmail it is.

Adding the code you are using will probably help debug the problem further.

On Wed, 1 Jul 2020 at 06:47, Veena Tarak <[hidden email]> wrote:
Hi All,

I am receiving "Return value must be dictionary" while trying to run the selenium script in Edge chromium browser.

getting this error right after the browser lauches.

This issue happens to only my application. same code is working for other web application (like google and gmail)

Could any one let us know what's wrong with my application.

Note: The same working with Chrome browser , seeing this only for Edge Chromium

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/8d2789fe-a1fa-47b5-bdc0-214094d8d59co%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CAJPyTs2LiQ%3D-FMB6z91B1mZNW5Y7ELE%2BJu%3D%3DH-RfevKDB%2B1j9Q%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: Selenium could not able to identify elements while running the application in Edge Chromium Browser

Sahil Chaudhary
In reply to this post by Veena Tarak
The best thing you can do is to highlight elements before performing any action. 

This will help you to understand whether your script is identifying elements on your application nor not.

For highlighting you can do that with javascript executor.

Thanks
Sahil Chaudhary

On Wed, Jul 1, 2020 at 11:17 AM Veena Tarak <[hidden email]> wrote:
Hi All,

I am receiving "Return value must be dictionary" while trying to run the selenium script in Edge chromium browser.

getting this error right after the browser lauches.

This issue happens to only my application. same code is working for other web application (like google and gmail)

Could any one let us know what's wrong with my application.

Note: The same working with Chrome browser , seeing this only for Edge Chromium

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/8d2789fe-a1fa-47b5-bdc0-214094d8d59co%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CAA2NVpOgmiPZYC%3DyqDXstgnZDC5sRYQ3h-BrPByGOfhvp2UThg%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: Selenium could not able to identify elements while running the application in Edge Chromium Browser

Veena Tarak
No, Its not identifying any elements.

On Wed, Jul 1, 2020, 12:11 PM Sahil Chaudhary <[hidden email]> wrote:
The best thing you can do is to highlight elements before performing any action. 

This will help you to understand whether your script is identifying elements on your application nor not.

For highlighting you can do that with javascript executor.

Thanks
Sahil Chaudhary

On Wed, Jul 1, 2020 at 11:17 AM Veena Tarak <[hidden email]> wrote:
Hi All,

I am receiving "Return value must be dictionary" while trying to run the selenium script in Edge chromium browser.

getting this error right after the browser lauches.

This issue happens to only my application. same code is working for other web application (like google and gmail)

Could any one let us know what's wrong with my application.

Note: The same working with Chrome browser , seeing this only for Edge Chromium

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/8d2789fe-a1fa-47b5-bdc0-214094d8d59co%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CAA2NVpOgmiPZYC%3DyqDXstgnZDC5sRYQ3h-BrPByGOfhvp2UThg%40mail.gmail.com.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CACC5KP9iWa6Couc8WbFahNYORNpMm9QD2utEJLdGWXjSkjn%2BTg%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: Selenium could not able to identify elements while running the application in Edge Chromium Browser

Joe Ward
As I said above it’s probably an issue with the page under test and how you are accessing it with code. Providing a sample of what you are doing can help debug further. 

On Wed, 1 Jul 2020 at 13:11, Veena Tarak <[hidden email]> wrote:
No, Its not identifying any elements.

On Wed, Jul 1, 2020, 12:11 PM Sahil Chaudhary <[hidden email]> wrote:
The best thing you can do is to highlight elements before performing any action. 

This will help you to understand whether your script is identifying elements on your application nor not.

For highlighting you can do that with javascript executor.

Thanks
Sahil Chaudhary

On Wed, Jul 1, 2020 at 11:17 AM Veena Tarak <[hidden email]> wrote:
Hi All,

I am receiving "Return value must be dictionary" while trying to run the selenium script in Edge chromium browser.

getting this error right after the browser lauches.

This issue happens to only my application. same code is working for other web application (like google and gmail)

Could any one let us know what's wrong with my application.

Note: The same working with Chrome browser , seeing this only for Edge Chromium

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/8d2789fe-a1fa-47b5-bdc0-214094d8d59co%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CAA2NVpOgmiPZYC%3DyqDXstgnZDC5sRYQ3h-BrPByGOfhvp2UThg%40mail.gmail.com.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CACC5KP9iWa6Couc8WbFahNYORNpMm9QD2utEJLdGWXjSkjn%2BTg%40mail.gmail.com.

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CAJPyTs01mf7UCsAYMJEusmMfJ_rQ2YmL0Jmq-WoJv_6%2BGVn9UA%40mail.gmail.com.