Selenium hangs on new browser window

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Selenium hangs on new browser window

GW-5
I need to verify a new browser window that is opened through the main window. However, when playing back the test in Test Runner (in IE), the new window opens, but then Selenium just 'hangs'. The verification commands are not executed.
Also, interesting to note, when I play the test back through FireFox, it opens two instances of the new browser window, but then Test Runner still hangs. I've tried adding a command to click on a link on the new page, to help set the focus, but that doesn't help. I've also tried replacing the ClickAndWait with just Click and that doesn't help. Any suggestions to what may be causing this behavior?

Here is my test:

        <td>open</td>
        <td>/dss</td>
        <td></td>
</tr>
<tr>
        <td>verifyTitle</td>
        <td>DSS - Home</td>
        <td></td>
</tr>
<tr>
        <td>click</td>
        <td>link=Cash Management</td>
        <td></td>
</tr>
<tr>
        <td>selectWindow</td>
        <td>BankContingencies</td>
        <td></td>
</tr>
<tr>
        <td>verifyTitle</td>
        <td>DSS - Contingency</td>
        <td></td>
</tr>
<tr>
        <td>verifyTextPresent</td>
        <td>Net Wires Due ($)</td>
        <td></td>
</tr>
<tr>
        <td>verifyTextPresent</td>
        <td>Contingency Funds Available ($)</td>
        <td></td>
</tr>
<tr>
        <td>selectWindow</td>
        <td>null</td>
        <td></td>
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.openqa.org/thread.jspa?threadID=1216&messageID=3482#3482

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]