WebDriverException: Message: Can't load the profile. Possible firefox version mismatch.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

WebDriverException: Message: Can't load the profile. Possible firefox version mismatch.

Reed Xia
Hi there,

I got the exception when using selenium + pytest + Xvfb with Jenkins:

E               selenium.common.exceptions.WebDriverException: Message: Can't load the profile. Possible firefox version mismatch. You must use GeckoDriver instead for Firefox 48+. Profile Dir: /tmp/tmpmon3g9gr If you specified a log_file in the FirefoxBinary constructor, check it for details.


See the version information:

13:19:17 + geckodriver --version
13:19:17 geckodriver 0.19.0
13:19:17 + firefox -version
13:19:17 Mozilla Firefox 58.0

Actually I tried some other version of Firefox and geckodriver, but still got this error, could someone tell which geckodriver or firefox version should I use?(Because I'm using an incorrect version mapping...?)


Thanks,
Reed

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CAB_-H09TYFMehT5pDgcT2vbDxdmkyQQkbrdmmHThtg9XwH8qfA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: WebDriverException: Message: Can't load the profile. Possible firefox version mismatch.

Reed Xia
I fixed this problem :)

Yes it's a geckodriver vs firefox problem, just now I downgraded Firefox to 46.0, it's working well with geckodriver  0.19.0.

On Mon, May 28, 2018 at 9:25 PM, Reed Xia <[hidden email]> wrote:
Hi there,

I got the exception when using selenium + pytest + Xvfb with Jenkins:

E               selenium.common.exceptions.WebDriverException: Message: Can't load the profile. Possible firefox version mismatch. You must use GeckoDriver instead for Firefox 48+. Profile Dir: /tmp/tmpmon3g9gr If you specified a log_file in the FirefoxBinary constructor, check it for details.


See the version information:

13:19:17 + geckodriver --version
13:19:17 geckodriver 0.19.0
13:19:17 + firefox -version
13:19:17 Mozilla Firefox 58.0

Actually I tried some other version of Firefox and geckodriver, but still got this error, could someone tell which geckodriver or firefox version should I use?(Because I'm using an incorrect version mapping...?)


Thanks,
Reed

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/CAB_-H08%3D2s1ox494owU0bgf%3DCC%2BZ%2BDvqqwYP%2BzOYUBNLeRVP3g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.