selenium-server-standalone-2.53.0 garbles Chinese character in the test result

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

selenium-server-standalone-2.53.0 garbles Chinese character in the test result

susansbb7
I use Selenium standalone server 2.53 on Windows to run a test suite recorded by SeleniumIDE with Firefox, such as the following command:
java -jar selenium-server-standalone-2.53.0.jar -htmlSuite *firefox http://localhost firefoxSeleniumIDETestSuite.html result.sel

In the test suite (firefoxSeleniumIDETestSuite.html), there is a test like this:
<tr>
 <td>waitForText</td>
 <td>link=退出</td>
 <td>退出</td>
</tr>

However, the test result in result.sel shows:
info: Executing: |waitForText | link=?????? | ?????? |
The link text is garbled and unreadable.

Is there a way to fix it?

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/385b574f-1d3f-4244-bc57-60f07fca0978%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: selenium-server-standalone-2.53.0 garbles Chinese character in the test result

阿修


susa...@gmail.com於 2016年7月5日星期二 UTC+8上午11時18分51秒寫道:
I use Selenium standalone server 2.53 on Windows to run a test suite recorded by SeleniumIDE with Firefox, such as the following command:
java -jar selenium-server-standalone-2.53.0.jar -htmlSuite *firefox <a href="http://localhost" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Flocalhost\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFGqUkBFzjtaT7Ud2VcduaSq6JAfQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Flocalhost\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFGqUkBFzjtaT7Ud2VcduaSq6JAfQ&#39;;return true;">http://localhost firefoxSeleniumIDETestSuite.html result.sel

In the test suite (firefoxSeleniumIDETestSuite.html), there is a test like this:
<tr>
 <td>waitForText</td>
 <td>link=退出</td>
 <td>退出</td>
</tr>

However, the test result in result.sel shows:
info: Executing: |waitForText | link=?????? | ?????? |
The link text is garbled and unreadable.

Is there a way to fix it?


Hello! 
Will you fix it?
I have the same problem. 

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/selenium-users/0b8c7546-f153-41db-bb33-15ffae6d9af5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.